PDA

View Full Version : NB100-12M - Touchpad weird behaviour



slavino
22.07.2009, 00:17
My touchpad started to act weird. On tap it acts like right button click, on left button click it acts as right button click and right button doesn't respond at all. In synaptics driver setup is everything set to default (so left button is default left button, right button is set as right button, etc.)

Is there a driver version that should work for sure? I tried the Toshiba suggested driver from support page and also a version where Windows XP recognized driver update. I also tried default PS2 driver that didn't work at all...

The netbook has only few days...what in the hell happened?

Thanks for any help :-(

Akuma
27.07.2009, 02:41
Try updating the BIOS. If that doesn't help, then the touchpad cable may be loose or the touchpad may be faulty.

Have you installed a 3rd party mouse or keyboard driver? Try removing that.

Does it happen in DOS as well? Boot from a DOS Boot disk and run a program that loads and uses a DOS Mouse Driver. I believe Hitachi DFT loads a driver. Google is your friend.

I assume the system is under warranty, so if you think its a hardware problem, send it to an ASP for repair.

Raver
27.07.2009, 09:50
Hi

Did you try an external mouse on the notebook?
So you can determine if itís a problem of the touchpad or installed software or drivers. Check this, it takes only few minutes!

If the external mouse works you should try to update the BIOS. On the Toshiba website you can download all driver updates for your notebook.
Before you update the BIOS you should close all running programs, disable your antivirus and firewall.

In worst case itís a malfunction of the touchpad and it must be replaced. :(

slavino
31.07.2009, 22:57
I updated BIOS from 1.9 to 2.0. The problem persists also after that.
I don't know how to fix cable for touchpad.
I had to disable the right button. It seems to be pressed permanently down (at least the Synaptics icon tells me that).

slavino
31.07.2009, 23:01
I tried external mouse today...it's high end Logitech wireless mouse (VX nano). But there was no such device before.
Could be touchpad HW buggy?