PDA

View Full Version : Ubuntu 9.04 on NB100



billaboard
14.06.2009, 19:20
I have rather a complex network here and tried to get the original 8.04 version of Ubuntu to work with it without total success. All was cured by installing 9.04 remix from a pen drive, and the machine now works really well apart from the following small problems.

1. The function key operations don't work. The ones relating to sound show the on-screen display following the keys correctly, but they don't actually do anything. With others things like the wireless is no longer controlled by the Fn on or off keys and neither is there any display.

2. I'm not sure about the power management or control of the fan or processor mode (not sure if it has low-power modes).The system log contains messages such as "ACPI: Unable to turn cooling device off".

If this were a Windows system, I'd be looking on the Toshiba site for the drivers relating to power management and keyboard, but there doesn't seem to be much in the Ubunto section of the download area, and presumably it would relate to the Hardy version rather than this Jaunty one.

Is there any guidance anywhere about how to proceed?

Message was edited by: billaboard

uli
15.06.2009, 19:48
I have also installed 9.04. Works nearly flawlessly. See also here: https://wiki.ubuntu.com/HardwareSupport/Machines/Netbooks
Fan-controll works, but the symbol doesn't appear on screen. Other funktion-keys are working: sound, sound on/off, brightness... Skype works (mic and cam).
One issue I have is that the symbol for a mounted pendrive, which you can use to unmount it,
is not shown on the remix desktop. Another that the nautilus-window is not maximized automatically.
I am still switching between the original 8.04 and 9.04.

billaboard
16.06.2009, 01:18
Thanks for this. Very helpful, as it made me revisit the settings for the audio, and I discovered that I hadn't set the parameters to be controlled. Set this in Preferences, Sound and now that all works.

The problems with the fan remain, I think. The trouble is that I only had 8.04 installed for a short time and can't remember how the fan behaved. The Fn + fan button brings up no display, but I can't detect any difference to the sound or airflow out of the machine. Also the kernel log contains a lot of lines similar to:

Jun 13 13:47:59 aaa kernel: [21358.123244] ACPI: Transitioning device [FAN] to D3
Jun 13 13:47:59 aaa kernel: [21358.123257] ACPI: Unable to turn cooling device [de813498] 'off'

Does this mean anything? The machine seems to get quite hot, but I think it always did. The aaa's are where I've blanked out the machine name.

I haven't yet found anything that I can set to make the Alt keys control the brightness.

I, too, have been using Skype under 9.04, sound and vision.

uli
16.06.2009, 17:58
I am now working with 9.04 which I have installed on a pendrive with usb-creator using the standard jaunty iso. I installed the remix desktop later seperately. If I do Fn+F8 I can hear that the fan turns more slowly / with higher speed. While working, the fan changes speed automatically if necessary. Fn+F9 dims brightness and with Fn+F10 brightnes goes up. Fn+F1 sets the wireless on/off, Fn+F6 the speaker. Fn+1/2 controls loudness.

Further I have done tests with battery time. I could not find significant differences with the original 8.04-lpia version that had been installed by Thoshiba. (about 3 hours)

With partimage (from the repositories) I have made images on a pendrive from both the 8.04 and the (on the harddrive) installed 9.04. So I can switch in a few minutes from hardy to jaunty. Each image has a size of ca 1,2 GB.

I can't comment on the kernel messages.

billaboard
17.06.2009, 21:17
That is interesting, as it does seem to differ a little from the results here.

With guidance from a very friendly expert, I installed acpi, which says is only meant to be a monitoring tool via Synaptic.

After this the sound controls still worked and the fan now responds to the correct keys and appears to be controlled by the machine temperature. The wireless Fn+F1 also switches the wireless on and off. The brightness controls still have no effect, though.
The kernel log acpi error messages have also not re-appeared, but seem to have been replaced by a success message about the fan.

I think I may take the machine back to its original state to see how it was with the original Toshiba build, then re-install and build 9.04 up to where I want to be from scratch. Is it simple to use Partimage with a pendrive and will it cope with the HD partitioned the way I have it ie with 2 ext3 partitions plus a swap partition? The Partimage website only seems to refer to CD operations and seems to say not multiple partitions. It also gives a warning on starting that I am not logged in as "root" and that it may not work correctly. This made me realise that I have no idea of the root password for the NB100.

I am a beginner with all this, so please excuse the stupid questions.

uli
18.06.2009, 17:53
Partimage is a program which is very simple to use.
Make a bootable ubuntu pendrive using usb-creator from the administration section and a standard ubuntu 9.04 iso. Boot from this pendrive. Install partimage with synaptic from the repositories on your bootable pendrive and start partimage with: sudo partimage

You don't need a root password.

Each partition must be saved seperately. Use a second pendrive to store the image created by partimage or a partition that is mounted but not the partition you save . If the pendrive you have booted from has sufficient memory you need no second pendrive, you can store the image on your boot-pendrive. I have two partitions 15 GB where ubuntu is installed + 64 GB for data. Using partimage with gzip-compression (preselected by partimage) an image of the ubuntu partition (3,4 of 15G used) takes about 1,2 GB. It is not sensible to make images from swap. Partitions you save/restore must not be mounted!
Saving takes ca 15 minutes, restoring 2.

uli
18.06.2009, 20:14
Look at this: http://www.psychocats.net/ubuntu/partimage