PDA

View Full Version : Cannot connect Satellite 1410-604 to WLAN when WEP in enabled



Fenix_D
02.05.2009, 03:34
Hello!

Well, I was looking througout this forum, but I was not able to find what is going on with this computer.

Laptop Info:

Toshiba Satellite
Model: 1410-604
WLan Card Installed:
Toshiba Wireless LAN Mini PCI Card
Controladora de CardBus Texas Instruments PCI-1410

According to what I was able to find up to now, (the laptop is not mine, I'm helping a friend to get solved this problem) this card supports only 802.11/b standard. This should not be a problem, because the A/P also does support 802.11B standard.

Anyway, there was absolutely no way to get the laptop connected to the WLAN...

Or, in order to be more correct: It does not connect to the WLAN when the WEP encryption is enabled (WEP or WPA gives the same: it seems to get connected, but never gets the IP from the DHCP), but everithing goes just fine if I turn off the WEP encryption.

The worst part is that the drivers installed do not support almost any configuration. The advanced configuration only supports the following:

1. Station name
2. Channel
3. Transmission speed
4. Card power management

Also, the card does not have any network manager (like others have, where it is possible to adjust some parameters, and get sure WEP is being used adequately).

I am not sure what is going on here. I was not able to get the card working in WinXP, and neither in LINUX (tried xubuntu, ubuntu, and knoppix).

I am starting to think this has to do with the card, and it's inability to work under WEP or WAP encription (it does work OK in open WLANs), and I cannot think of how to solve this.

It seems there are no newer drivers than what I have (downloaded from Toshiba),
I don't know if a BIOS update will solve this, most probably not.

Maybe the card is just too old... but If Im not wrong... It should work. Shouldn't it?

Any ideas are absolutely wellcomed!

Best regards,


Fenix_D

Jimi
02.05.2009, 12:53
Hi

Seems like this card has been manufactured by Agere (this is WLan driver which appears on the Toshiba page).
The INF file provides some details and the driver seem to be from 12/19/2001 v7.42.0.300

However, the WEP or WAP encryptions are hardware based features and if the hardware (WLan card) does not support this then a driver update would not help you!

But what you could check is the option in device manager -> Wlan card -> properties -> “Advanced tab”
Usually there are all necessary settings and if the encryption would be supported then you should find it there.

If this will not help you then I recommend buying an USB WLan stick which would support the newest encryptions…

Fenix_D
04.05.2009, 15:07
Hi Jimi!

Well, if you pay attention to my first post, I say:

"The worst part is that the drivers installed do not support almost any configuration. The advanced configuration only supports the following:

1. Station name
2. Channel
3. Transmission speed
4. Card power management"

I was meaning the "advanced" tab in the device properties in device manager... :(

This is not the first WLan I install, and I do know how to handle them, but this is the first time it seems no way to configure it to my needings.

For what I was able to find up to now, it seems this card seems to support no encription at all, or (if it does support any) it could only support the eldest ones, maybe 64 bit WEP encription...

It only supports 802.11B, and does not support G or N... (rather old card).

But, the computer does not support USB 2.0 either, therefore it is also problematic to use an USB adapter. I tried one ENCORE ENUWI USB adapter, and it was absolutely impossible to make Windows to even recognize it (and it works perfectly in other machines).

I was able finally to use a PCMCIA wireless card, also quite old, and also B standard, but at least this card allowed me to set WEP and WAP encription through it's own WLAN manager.

:)

Best solution up to now...

(a) Get rid of WEP encription and use MAC ACCESS filter, in order to stay connected with this card.
(b) Completely uninstall this card (phisically removing it) and install the PCMCIA card.

Any solution will work... but what I would like to go is to make the first one work.

;)

Jimi
04.05.2009, 15:25
Hi Fenix

Thanks for the feedback…
The suggestion about “Advanced tab” was just a additional tip in case you wouldn’t know this… but it seems you known this already ;) that’s fine…

Anyway, as you said it seems that the WLn card (hardware) does not support this kind of encryption and in my option you will not get it to work since it’s a hardware limitation.
So I would agree with you and maybe the PCMCIA option is a best solution for you…

Cheers dude…