View Full Version : Satellite A300-1OM wirless connection changed from connected to limited

22.04.2009, 01:17
I am having issues with continual use of the internet via my wireless home network, which appears to be an intermittent problem.

On many occasions while using my wireless internet connection the connection has changed from 'connected' to 'limited connectivity', which then leads to difficulty opening the 'Network and Sharing Centre' and also 'Connect To a Wireless Network' dialog boxes, and when attempting to diagnose the problem using windows it only suggests moving closer to or restarting my wireless router, which I know to be work fine as I can operate another toshiba laptop and browse the internet using the same router in the same location.

It seems the only method to repair this problem is to restart the computer, reopen the Network and Sharing Centre, click on the red 'X' between the graphic of my computer and the image of the earth (internet) allowing windows to diagnose the problem, and then choose 'turn on wireless connectivity', and after doing this the network begins operating as normal...until it repeats the malfunction a few hours later :(

22.04.2009, 08:55

At the moment I canít say the reason for this issue but you can try this:

- Update the WiFi driver (http://aps2.toshiba-tro.de/wlan/)
- Update the BIOS (you can find it on the Toshiba website)
- Check the WiFi standard (e. g. 802.11g; it should be the same on notebook and router).

Which OS do you use?

Maybe the problem can be solved if you reset the router.


22.04.2009, 14:17
I've updated the WiFi Driver and BIOS, how can I find out what Wireless standard my notebook is using? As you can imagine with an intermittent issue, I won't know if the problem is fixed until (if) it fails again.

I'm using Vista Home Premium

With regards to restarting the router, why might this make any difference when it is evident from using two toshiba notebooks side by side that the router is still providing internet access to my other notebook once this notebook has downgraded to 'limited connectivity'?


22.04.2009, 14:51
The WiFi standard that your notebook uses you can check in device manager > right click von WiFi card > properties > wireless mode

Furthermore you should disable the WiFi power saving function of Vista. This document can help you to disable this feature:

Good luck!

22.04.2009, 15:28
The notebook appears to be running on 802.11a/b/g, so should operate fine with my Belkin router.

The wifi power settings are already on 'max performance' option.

I guess with the things i've done according to previous posts i'll just have to wait a few days to see if it does it again. I'll post back if it does, or mark as answered if it seems to have been fixed.

Thanks guys!