PDA

View Full Version : Slow WLAN with my Satellite P300



joskin73
19.03.2009, 13:35
I bought a Toshiba Satellite P300 with Vista. I don't like Vista so I installed WXp instead.
The trouble is that I have a very bad speed in my wireless network 1.15 mbit/second, with a another older notebook I have 10/15 mbit/sec.

This is a problem and I don't know how to fix it.
What network card/wireless should it be in the computer???
After the xp installation the computer didn't find any, I've try a few things now a Atheros card is in the list.

HELP:::::

Barrie
19.03.2009, 14:05
Hello

Which BIOS version is installed on your Satellite notebook?

Luke
19.03.2009, 14:25
Hello

Check the BIOS as Barrie said. Maybe you should update it.

Did you already install a driver for the WiFi card? On the Toshiba website I can find 3 different WiFi drivers for the Satellite P300. Look on the bottom side of the notebook. There you can see the model number and with this number you can choose the right driver.

http://eu.computers.toshiba-europe.com => Support & Downloads => Download Drivers

Greets

joskin73
19.03.2009, 22:11
V2.50 is the Bios version if i looked right. I have tried all three drivers..The atheros driver is thats working but very bad...
The answer i get from Atheros was this:

Thank you for your interest in products containing Atheros
Communications' technology.

However, we do not offer the wireless cards or drivers
that you're inquiring about. Atheros typically sells
chips to module manufacturers and therefore would not be
able to help you with this task. For issues regarding
configuration and usage of your product, please contact
the card and/or computer manufacturer's technical support
department. We suggest you refer to the manufacturer‚??s
website, as they typically offer online technical support
pages where software drivers, updates, and other related
information can be obtained.

Thank you for your understanding.
Atheros Communications, Inc.

This is what i see in the Device Manager
Network:
1394 Net Adapter
Atheros AR9281 Wireless Network Adapter
Marvell Yukon 88E8040T PCI-E FAst Eternet Controller

///Mattias Umeå Sweden

joskin73
19.03.2009, 22:18
The Bios version is V2.50 if i understand it right.
I tryed all three drivers, the atheros driver is the only one whos working but bad.....

I get a answer from Atheros and it was this:

Thank you for your interest in products containing Atheros
Communications' technology.

However, we do not offer the wireless cards or drivers
that you're inquiring about. Atheros typically sells
chips to module manufacturers and therefore would not be
able to help you with this task. For issues regarding
configuration and usage of your product, please contact
the card and/or computer manufacturer's technical support
department. We suggest you refer to the manufacturer‚??s
website, as they typically offer online technical support
pages where software drivers, updates, and other related
information can be obtained.

Thank you for your understanding.
Atheros Communications, Inc.

????????????

In my Device Manager it showing this:
1394 Net Adapter
Atheros AR9281 Wireless network adapter
Marvell Yukon 88E8o4T PCI-E fast eternet controller

Can this be wrong or what???? I dont understand this..

/Mattias Umeå Sweden

joskin73
20.03.2009, 08:47
I have tried all three drivers...the only one whos working is Atheros drivern.
The Bios version is V2.50.

/Mattias Umeå Sweden

Barrie
20.03.2009, 09:32
Hello

On Toshiba download page you will find new BIOS update version 3.00. before download starts small notice will be shown:

*Notice*

*This program will check OS version and WLAN type to decide driver updating or not.*
*1. For Windows XP image: Update BIOS only*
*2. For Windows Vista 32 image with Atheros WLAN: Update WLAN driver (version 7.6.0.164.1 or higher) and then update BIOS*
*3. For Windows Vista 32 image with Intel WLAN: Update BIOS only*
*4 .For Windows Vista 64 image: Update BIOS only*

So if you have Vista and Atheros WLAN card please follow notice number 2.

I hope this will help you.

joskin73
20.03.2009, 18:31
Hello Barrie...

THANKS:.......I did the things you say and now my internetconnection is pending between 18-22 mbit/sec....nice....

Thanks again....

/Mattias Umea Sweden

Lars-539581805
20.03.2009, 19:23
Great news!

If you have more questions, just start a new topic.