PDA

View Full Version : Re: Satellite L300-1DN - Can't connect to the internet



scarfy
01.03.2009, 17:03
Hello guys! I recently bought a Toshiba laptop - Satellite L300-1DN and I cannot connect it to the internet via wireless or cable.

I tried switching on the wireless button and my laptop recognised my the wireless network of my house, but it just could not connect. Then I tried plugging in the cable, but my laptop connected itself to an "unidentified network" and internet still not working :(

The internet is working perfectly well for my other housemates and for my old laptop. So I guess there isn't a problem with my router itself.

I do not know computers very well, so I would really appreciate your professional opinions!!!

Thank you very much!
Scarfy

Paul2008
01.03.2009, 19:25
Hi scarfy,

Firstly, please try getting a bit more information about what happens when you connect via Ethernet, to do this please follow the instructions below:

Go to the *Start* button and in the bottom-left of that menu you will see a *Start Search* box
In this box, please type in *CMD*, then hold CTRL+ALT and press enter, click *OK* on the user account control pop-up
Within the new DOS box that appears, please type *ipconfig* and press enter
Find a heading called *Ethernet adapter local area connection* and please reply with the *IPv4 Address*

If you can reply with this information, we can take it from there.

Regards,

Paul2008

Luke
01.03.2009, 19:27
Hello

Try to update the WLAN and LAN driver. Both you can find on the Toshiba website:
http://eu.computers.toshiba-europe.com
Make also sure that you have the newest BIOS version installed:

Try to disable the security features on the router and then try it again to connect.

Make sure that you donít have a virus or something else on your computer that blocks a network connection.

Greets

scarfy
01.03.2009, 21:39
Thanks Paul!. I followed your instructions but all I could see in the DOS window under "Ethernet adapter local area connection" is "media state...media disconnected...connection-specific DNS suffix". This is even when I've turned on the wireless button.

One more thing, I tried connecting to an unsecured wireless network and it worked!

Scarfy

Raver
01.03.2009, 22:54
> One more thing, I tried connecting to an unsecured wireless network and it worked!

Looks like a problem with your router. Check this and look on the manufactures website for a firmware update.

Make sure that the notebook and router uses the same WiFi standard (for example 802.11g).
Disable all power saving features from the WLAN card in device manager.

Last but not least follow the instructions that Luke posted.

scarfy
02.03.2009, 00:00
Thanks Raver! But how/where can I check the WiFi standard thing?

Scarfy

scarfy
02.03.2009, 00:17
Thanks for your suggestion Luke! I just downloaded the most recent version of BIOS update that I could find on the website. Do I just install it onto my Toshiba laptop and then try connecting to a wireless network?

I also checked out the downloads available for Wireless Lan Drivers. The search results show three different companies and I'm not sure which one I should download from. Also do I also install them onto my Toshiba and then the internet should work fine?

Date last modified Company Operating system Version
01/12/08 Atheros Windows Vista 32 Bit 7.6.0.164.1
17/11/08 Intel Windows Vista 32 Bit 12.0.0.73.0
16/09/08 Realtek Semiconductor Corporation Windows Vista 32 Bit 5.1116.1226.2007
04/06/08 Realtek Semiconductor Corporation Windows Vista 32 Bit 6.1226.1004.2007

Scarfy

Paul2008
03.03.2009, 14:01
Hi scarfy,

Sorry for the delay in replying.

The wireless driver that you would need to download is the *Atheros* one.

If you can connect fine to an unsecured network, but not your encrypted network, have you tried resetting the router? This sometimes can make the wireless and the Ethernet connections work.

As for the BIOS update, if you are going to run an update on the BIOS, ensure that your notebook is connected to the mains, the BIOS version you want to download is *1.60-WIN*. When you click on it, you should save the zipped file somewhere you can find it again (usually the desktop), once downloaded right-click on the zipped file and select *Extract All*, a wizard appears where you just want to click on extract. This will open a new window and you want to open the folder and double-click on the file named *PS10160M* and just follow the on-screen prompts.

Good luck,

Paul2008

scarfy
03.03.2009, 22:44
Hello Paul!

I've tried everything you told me - updating the drivers and BIOS, resetting the router. And it's still not working :(

is there a problem with my wireless card? But it's brand new? I'm really helpless >.<

Scarfy

Paul2008
04.03.2009, 15:10
Hi scarfy,

OK, providing everything has installed correctly and you are able to connect to another unsecured network, I would say try taking all encryption off of your router for a short period of time to see if you're able to connect then. If you can, it may be worth changing the encryption from *WPA* to *WEP* or vise versa, because the wireless card in your notebook might not work properly with one or the other.

Let us know how you get on :)

Paul2008

Foysol
09.03.2009, 03:07
I had similar problem today, but both my LAN and WiFi could not connect at all. I used Toshiba Recovery, and reinstalled my laptop to factory setting (yes lost all my file - but they are backed up so I can get them back again), not something we like to do again and again, but it did solve the problem.

What I would like to know, why did this problem occur in the first place? How can this be avoided in future?

Luke
09.03.2009, 09:27
Hello

> why did this problem occur in the first place?
Thatís not easy to say but I think this was a software issue because after you have reinstalled your notebook with the recovery disk the WLAN and LAN works again.
Maybe a software was installed that causes the error or you had a virus on your notebook.

A friend of me has a Satellite L300 notebook too and he never told me about such problems. It works perfect.

Greets