PDA

View Full Version : Portege 7220 - problem replacing hard drive



colorado_bob
24.02.2009, 04:08
I have a Portege 7220 CTe running Windows 98se. The hard drive is slowly deteriorating (bad sectors), so I decided to replace it. The old drive is a Toshiba 6GB. The new one is an IBM/Hitachi Travelstar 10GB - supposedly and apparently unused though dated Sept 01.

Executive summary: The drive worked once in the Portege, but doesn't any more. It continues to work fine through a USB interface to another system.

I have done the following. (I'm sure there are many irrelevant details, I just can't tell which might be relevant):

- Checked new drive with Hitachi's Drive Fitness Test. Ran this on the Portege, booting from a CD in the docking station. The drive checked out perfect.
- Made an image backup the old drive on another machine (XP desktop) using a USB enclosure, and Macrium Reflection.
- Restored the image to the new drive (using the same USB enclosure).
- Ran XP's scandisk and defrag on the restored drive (no problems, did significant defrag)
- Cleanly removed USB drive from XP system, and drive from enclosure
- Put new, restored drive into the Portege and powered up.

The system failed to boot, saying (indirectly) that HIMEM.SYS was missing. I hooked the drive back to the XP system. Indeed \WINDOWS\HIMEM.SYS was missing, as well as most of the rest of the contents of \WINDOWS. The rest of the contents matched the backup. ???????

I copied \WINDOWS from the backup image to the new drive. Cleanly removed from the XP system, and put in the Portege.

System booted to Win98. I tried starting a random application, and the system became nonresponsive.

From this point I may not have all actions in order, but I doubt that matters. I tried the following:

- Running Hitachi Drive Fitness Test. It first found the drive but reported a "drive not ready" error. After repeated attempts to re-seat thedrive, check on the XP system, etc. it fails to find the drive at all
- Going into the BIOS at boot. Sometimes it found the drive, sometimes not.
- The XP desktop still recognizes the drive fine through the USB interface. Scandisk is happy with it, including surface scan. The Hitachi utility only runs with ATA or SCSI, and I don't have a desktop-laptop ATA adaptor.
- Did a fresh restore of the backed-up image. This worked fine, but the Portege still wouldn't find the drive.
- Tried the old drive and a 6GB travelstar from another system in the Portege. Both work fine.
- Tried the new drive in a Portege 7020. Fails just like in the 7220.

I thought maybe it was a power issue. But both Travelstars (the one that works and the new one that doesn't) are rated 500mA. The old Toshiba drive that also still works is rated 700mA.

Any ideas would be greatly appreciated.

kjo-538152471
24.02.2009, 22:14
apparently there is something wrong with your 10gb travelstar, maybe the MBR or the bootsector

the fact that you can read it with a USB-connector doesn't mean that the HD is okay, since you don't need the bootsector that way

I would advice you to wipe it completely ( with cleandisk or boot-it-NG ) , make a new partition with fdisk and reformat the HD to fat32

Than make a fresh install with W98, or better : W2000, which will run easily on a 7220 and is much better

To install W2000, it's best to copy the whole i386 directory of the installation-CD to the 10gb HD ( can be done on another PC with a USB-connector ) and start the DOS-installation with WINNT.EXE
More information about this issue you can find here :
[t-23921]

colorado_bob
27.02.2009, 11:16
Thanks, kjo, but wiping the drive didn't help. Why would anything on the drive affect whether the Hitachi utility or the BIOS find the drive?

In trying, the Hitiachi utility once found the drive at boot, but couldn't find it when I tried to run a test (reported "drive not found") - then never found it again.

My best guess is some problem that makes the drive require something (probably power-related) that it's not getting from the laptops.

kjo-538152471
27.02.2009, 20:49
normally 2.5" HD's are powered only by the IDE-cable through the controller on the mainboard
the fact that 2 other HD's are working good in your 7220 makes it unlikely that there is something wrong with the power-supply

I own several older porteges, f.e. a 7010 in which a 30gb HD is running perfectly, so it can't be a bios-restriction

_+first+_ : DOS-based utilities will only recognize simple file-systems, like FAT en FAT32, f.e. NTFS is never recognized and given as : "drive not found"

What is the file-system on your 10Gb HD ?? you can see it when you connect it with the USB-interface on your XP-machine in "properties" ( right mouse-click )

_+second+_ : when there is a faulty MBR ( master boot record ) or a damaged boot sector, the HD will never boot but *seems* completely normal with a USB-interface on an XP-system

if you really wiped the HD completely ( that means also deleting the MBR ), made a newMBR and did a proper reformat to fat32 ( use boot-it-NG, which is very powerfull ) it can only be a hardware-problem I fear you can'f fix

colorado_bob
28.02.2009, 05:41
I don't think the problem is in the power supply - rather that some problem in the drive requires more power than the IDE specs. The USB interface is meeting that requirement, but the Portege is not..

The file system I had on the drive (before wiping it) was FAT32. It was a copy of the file system from the old (dying) drive. The MBR was copied as part of that process (at least the utility told me it was doing that).

The Hitachi Drive Fitness Test is a standalone system booted from CD-ROM. It's a diagnostic, not interested in booting from the drive. Why would it care what file system or MBR is on the drive in order to find it?

I just booted Drive Fitness Test again to check something. This time it found the drive. Testing it reports
* Failure Code 0x71 Device Not Ready (The selected drive is not ready for operation. Check cabling and HDD connectors.)
* Technical Result Code 0x7102BD66 (can't find any further documentation for that)

The vendor who sold the drive to me has agreed to take it back as defective. I'm still curious, but probably not enough to try anything unless it seems likely to give new information.

Thanks for your help.