PDA

View Full Version : Satellite Pro P300-1EC - Can't get wireless to work



Mrjens
11.02.2009, 21:06
Hi!

First of all. Excuse me for my English!

Tech Spec.

Toshiba Satellite Pro P300-1EC
Intel WiFi Link 5100
Windows XP Pro SP3


I've a big problem. I cant get the Wireless LAN working properly.
And the client bought this computer because his old computer stopped working with WLAN...

I have tried everything I can. And I am a tech educated person so I think I should have the knowledge of this but I haven't.

Short version.

1.Installed the latest drivers.(Also tried older)
2.Restart the computer.
3.WNIC takes about 10min to find WLAN.
4.Then it is working perfect with 130Mbps on draft N.
5.I can logout and change user and everything.
6.When I restart I'm back to number 3.

Long version:

I've installed XP pro from the included XP downgrade Cd's and the wireless drivers wasn't on that CD so i downloaded them. (And yes. It's the correct drivers.)
After I installed the driver and reboot my computer I couldn't find any wireless networks. Kind of weird because I've have about 4 WLAN routers/APs on my company with 60-100% range and about 3 others public routers with no security on. I tried to update the drivers to windows update and WU found an update for me. I installed that driver and the wireless start working. I shout YES and reboot the computer. Then it stopped working. NO!!!
I was a bit tired on the problem and started to install some other computers that I bought and when I looked at the Toshiba computer I saw that it was connected to my WLAN. Wierd but I thought it was working so I restart the computer again and then its not working.. again! Now I have analyzedthe problem and it's like this.

When I start the computer the my WNIC doesn't find any WLAN.
About 10min (10m32s) after startup the wireless starts working.
I'm able to logout and change user and it still working but as soon as I restart the computer it stops and I have to wait another 10min. And so on.

Does someone been trough something like this even if its not toshiba or my model?

R2D2
16.02.2009, 16:38
Hi

Does the Satellite Pro P300-1EC BIOS is up to date?
Please check this firstly.

You said you are using Draft N. Did you try to establish the WLan connection using other WLan standard like 802.11 A or G?

I would also recommend changing the WLan channel and trying other channels.

Furthermore you can change some WLan option which affects the WLan functionality. You can find these settings in device manger -> WLan card -> properties -> advanced tab

Bye

Andrej
16.02.2009, 17:07
Hello Mrjens

Which BIOS version is installed on your notebook?
Please update BIOS to version 2.5 and check WLAN functionality again.