PDA

View Full Version : Touchpad stopped working on NB100-12A



jonsson_84
04.01.2009, 20:35
Hello!

The touchpad on my NB100-12A suddenly stopped working. Both the touchpad itself and the buttons do not respond. I have reinstalled the driver in Windows XP but it didn't solve the problem.

/Johan

Retronana
04.01.2009, 22:37
Hi,

Have you tried checking its status using device manager ?

Might be worth uninstalling it as a device, searching for the device and then letting it re install the XP drivers, then re-boot and see if that helps.

Let me know if that helps.

Stephen

jonsson_84
05.01.2009, 01:04
Yes, everything looks normal in the device manager. I have tried reinstalling it the way you mentioned but it didn't help.

Retronana
05.01.2009, 23:20
Not looking good...

I assume its showing as working correctly in device manager (the drivers are loaded and working ok ?)

2nd tab on the actual device on device manager, is advanced, have you tried clicking the restore defaults check box ?

fmcnamee
10.04.2009, 15:05
Same problem. I bought the Toshiba NB100 a week ago. The first time I used it, it worked perfectly. Since then the left mouse click on the touchpad is not working. I have reinstalled the driver etc, device manager tells me everything is fine. Very frustrating on a new machine. Any advice or suggestions very welcome.

blifil
09.05.2009, 12:50
NB100-12A
Windows XP Home

My 'tap' and left button function didn't work from the box. I attached a tablet and got through set up and updates hoping to be able to fix it but haven't been able to. Called support and they said it needs to go back. On the synaptics icon in the task bar, the left button light is 'lit' permanently. When Computer boots up and you move the cursor, the cursor draws a rectangle as if the left button is being held down. I have uninstalled and reinstalled. Also found a solution on web where all power is removed, but this hasn't worked either.
V irritating.

duncannb100
24.05.2009, 19:00
blifil - did you manage to fix your problem. My trackpad has done exactly the same. I bought a Ubuntu NB100 but couldn't get on with it and the right button didn't seem to work. So I installed XP and had the same problem you describe although not consistently. I then tried 8.10 Ubuntu which worked for a while but now neither button works!!! Think it might be going back tomorrow.

Duncan

federkicco
11.06.2009, 12:49
hi,
I have exactly the same problem with the touchpad on my new NB-100, I had to disable the left key as a temporary workaround in order to be able to use the pc.
Did you solve the problem by replacing the pc through support?

Thanks,
Federico

sk7
13.06.2009, 12:57
I have the exact same problem since two days with my NB100. The left button of the touchpad stopped working under XP. I had to disable the button too. Seems like a larger hardware problem with the series.

datalog
19.11.2009, 17:05
The Touchpad on my NB100 (Silver - Windows XP) started misbehaving after six months. Every button click shows the right context menu instead of say, simply opening the file. Looking at the animated icon in the taskbar it would appear that the first press of a button causes it to stick down and make use tricky.
Followed the idea above I've disabled the button. Now I use a mouse most of the time.
It seems that the left /right buttons are switched round and the settings are back to front.
I would like to hear of a combination of button settings that work round this.

adele1999
17.01.2010, 06:03
Hi, all,

I have experienced exactly the same problem since last week, I did reinstall Winxp system , but the issue still existed.



Strangely, the keyboard F7 , F4 have no indication of any function, I did try FN+ F7 and FN+ F4 , nothing happened either.


Any comments on this issue?




Thank you.


adele

KevinT
16.05.2010, 10:52
I have also experianced this problem. My left hand button has stopped working after 6 months. The behaviour is consistent with a stuck button on my NB100.

KevinT
22.05.2010, 19:17
I have just fixed my NB100. The left hand touchpad button had stopped working. It now works.
I have invalidated my warranty by doing this.
This was done by dismantling the computer (not for the fainthearted). Note: Antistatic precautions are required!!
I measured the resistance across the left hand and right hand buttons. The left hand measured as a lower resistance.
I then disconnected the flexible PCB strips which connect the small PCB with the buttons to the computer and reconnected them.
I replaced some screws and powered the computer. The left hand button was now working.
I then re-assembled the computer and it is fully functional.
My best guess is that a tin whisker or a dendrite had fomed on the flexible PCB strip where it enters the connector. Unplugging and re-plugging removed this partial short.

When re-assembling, I shook the computer and heard a rattle. I re-opened and shook out a washer. I cannot guess where it came from, but it doesn't appear to affect functionality. Any idea where it came from?

This message has been typed on my (now fully functional) NB100.

datalog
19.11.2010, 17:01
I wrote earlier about disabling the Touchpad buttons and using a mouse to work round the fact that the left touchpad button continues to stick.
So I tried KevinT's suggestion to open the system, disconnect the three touchpad flexible ribbon cables and reconnect them. Strangely this has got everything working again - though the business of dismantling the NB100 was scary indeed and risked disaster. Here are some tips if you dare:

First check that the left button isn't physically sticking when would be a lot easier to fix. Next Google for a pictorial dismantling guide for the NB100

Remove the battery, all the long F10 screws and short F5 screws from the underside and the screw in the battery compartment.
Levering from the centre pull up and remove the plastic cover between the keyboard and screen
Remove two small keyboard screws. Remove the four long screws under the keyboard. Remove the keyboard with its ribbon; unplug a small plug and prise the front silver and black parts but a cm or so. You'll only just be able to access the two ribbons under the touchpad. For each flexible ribbon connector remember to gently flick up the black latch before removal. Remove and blow clean. Use tweezers on the blue strip to reinsert the ribbon squarely in its slot. Then flip the black lock down. Good luck. If it doesn't work for you please report back here.