PDA

View Full Version : Satellite U405-S2833 Fingerprint Error: failed to open sensor



Guarani
27.12.2008, 22:00
Hello, I am very new to forums so I apologize ahead of time if I don't give all the correct information needed info in this thread.

I have a Toshiba U405-S2833 and it came with the TrueSuite Access Fingerprint Software.

I downloaded an update a few days ago but I cannot remember if it was for Vista or Toshiba. Since then, my fingerprints were all deleted from the system and when I try to re-register them, I get this error message "Error: failed to open sensor" I can't find the hardware to manually fix the sensor without going through the TrueSuite software.

Any help would be greatly appreciated.
Thank you in advance

rewind22x
31.12.2008, 15:56
I'm also having the same issue.

My boss uses a Satellite U405-2628 with the TrueSuite Access Manager and fingerprint sensor. Everything was working fine, then I updated windows and it stopped working. I looked back at the updates and noticed a TrueSuite update and thought maybe that had messed things up.

Then there were some other issues that happened that locked me out of the machine (Anti-Virus and loss of relationship with the domain... also my fault). So I decided to wipe the machine and install Vista fresh.

I got everything installed yet the TrueSuite software still could not open the sensor. After banging my head on this, I decided enough was enough and I restored using the Toshiba Recovery Discs.

That took a couple of hours and here I am, logged in under Administrator and the TrueSuite software still can't open the sensor. I'm not sure what else I can do, since it is back to factory settings.

As the above poster noted, HELP!

Thanks.

.... a little later....

Well, I got it to work, and this may be of use to some people out there since I haven't found any easy answers. I can't gaurantee anything and this is really convoluted... so here we go.

I first downloaded the newest update from Toshiba (util_fingerprint_27460A.exe), installed it and nothing worked.
Then I uninstalled the sensor from the Device Manger (right click, uninstalled) making sure to uninstall the driver as well (it should prompt you to do this)
Then, still in the Device Manger, I scanned for new hardware and it came up with my sensor. I told it to look for drivers and when it didn't find any, I think It gave me an option for windows to search for an answer... or something like that. It returned with a link to Authentec (www.authentec.com/win7update/w7wbf32.exe, i think). So I downloaded that and installed it. It moved the device up under "Biometric Devices" whereas before... i think it was under "Personall security device" or something like that. But alas, still no luck. So i uninstalled everything, the device from the device manger (taking care to uninstall the driver as well) and TrueSuite software. Then came the break i was after.

Searching online i came across this page...http://members.driverguide.com/driver/detail.php?action=download&driverid=1194755. I've had luck before at DriverGuide.com so I thought what the heck. It's an HP driver for the same sensor and it's dated 2006. So i downloaded it and installed. Still nothing...

Bummed, I thought, well let's try installing util_fingerprint_27460A.exe over the top of that. So I did that, restarted and I seriously couldn't believe my eyes when it said to login and enroll fingerprints. And so I did. I hope this helps people, I really don't know how the sensor got so messed up, but I'm glad it got sorted out.

One more thing... and this may be important. When I got into TrueSuite the first time after doing all this, it told me that the Fingerprint storage was full... or something along those lines. So i clicked the delete all fingerprints button and it let me enroll my fingerprints. I'm beginning to wonder if that was all i needed to do in the first place... Guess I'll never know.

Good luck.

Message was edited by: rewind22x

rewind22x
31.12.2008, 19:25
Ok, one last remark.

I really think that deleting all of the fingerprints did the trick. So I would try that first before messing with the drivers. just my 2 cents.
Good luck.

Guarani
02.01.2009, 22:51
Dear rewind22x,
Thank you so very much for all the info. I ended up uninstalling TrueSuite Access and installing the Authentec update and it worked!!! I was worried I would have to go back to factory settings...
Again, thank you so much for your help!!!!!!!

Akuma
30.01.2009, 04:57
SOLUTION:

The Fingerprint database is full and needs emptying.

Go to:
Start -> Programs -> TrueSuite Access Manager -> *TrueSuite Access Manager with Admin Privileges*

Enter your Windows password, and click "*Delete all Fingerprints*"