View Full Version : WLAN has stopped working - Satellite X200/N00, Vista 32-bit Ultimate (SP1)

Bruce Probst
06.12.2008, 12:55
When I purchased this laptop earlier this year, everything worked pretty well with no significant issues. A few weeks ago, however, my WLAN connection stopped working -- specifically, it does not get a valid IP address from the router.

Notebook is a Satellite X200/N00 (PSPBUA). OS is 32-bit Vista Ultimate (SP1).

It was working fine right up to the point where it stopped working. The router itself still works fine -- I have used the wireless connection with a completely different laptop since having the problem on the Toshiba.

This seems to be a fairly common Vista issue, but so far everything I've tried has failed to get me anywhere.

The router is a D-Link DSL-G604T. I have updated it to the latest version of firmware, but this has not made any difference.

In Vista I have disabled IP v6.

I have installed the latest version of the Intel wireless driver (v12.1.2.1). The hardware passes all self-tests, the only thing that fails is obtaining the IP address.

I don't know why the wireless connection just stopped working -- as best as I can recall, I had not installed any new software or updates just prior to it stopping working. It doesn't seem to be a hardware fault.

One thing I have not yet done is test the connection with a completely different wireless router (e.g., at a public access point).
That may be instructive, but not really useful, since I need to get it working with the router I have!

Any thoughts?

06.12.2008, 13:48

There are many different reasons why the IP address cannot be obtained.
In first case you should check if your firewall is disabled or doesn’t prevent the IP address from receiving.
Secondly you should check if the TCP/IP protocol was set to “automatic”
You can find such settings in TCP\IP protocol properties.

Last but not least I would recommend disabling all security settings on the router and trying to establish the WLan connection.
Please check if the Mac address filtering was disabled, disable the WLan encryption, and check if the right SSID is in use.

If it will be possible to establish the Wlan connection then you could enable step by step the single WLan security settings on the router.