PDA

View Full Version : Satellite U400-119 - battery not recognized



mogs01
09.10.2008, 10:14
Hi,

I've just bought a TOSHIBA SAT U400-119 laptop. The operating system is Windows Vista Home basic.
Before I turned the laptop on, I connected it to the DC adapter and let the batteries charge for 24 hours.

However, after 24 hours the LED icon for the battery is orange and blinks (meaning the battery power is low according to the users manual).
When I tried to turn the laptop on without the DC adapter the laptop didn't respond. So I installed Vista while the laptop was still connected to the DC adapter.

After installing though, the icon for the battery in Vista shows a red cross across the battery icon, meaning it is not recognized.
It's a brand new laptop so I think the battery should be replaced, but I'm not sure.

Did anyone had a similar problem?
Any sollutions for my problem?

Many thanks in advance!

Chad
09.10.2008, 10:19
Thatís a really interesting posting because a friend of mine have got the U400 notebook and a similar issued happened too.
Suddenly the battery was not recognizedÖ I thought itís a battery malfunction. But I was wrong.

The solution is very easy.
You need to update the BIOS and this should help you to get rid of this strange issue.
My friend did the same and it worked!

So check it out. Download the compatible and right BIOS and update it!!!

Bye

mogs01
09.10.2008, 11:06
Thanks for responding!

Shouldn't it allready be installed with the latest BIOS version since it's a brand new laptop?
Anyway, I think I'll try out your suggestion about updating BIOS.

I checked out the download site of toshiba-europe for the latest version of BIOS for my laptop. When asked to chose the product type, the model No is asked, but I'm not sure where to find this number for my laptop: TOSHIBA SAT U400-119 (PSU44E, PSU42E, PSU4CE or PSU40E ?)

By the way I have Win Vista Home premium installed on my laptop.

thanks again

bye

Message was edited by: mogs01

Chad
09.10.2008, 11:18
> When asked to chose the product type, the model No is asked, but I'm not sure where to find this number for my laptop: TOSHIBA SAT U400-119 (PSU44E, PSU42E, PSU4CE or PSU40E ?)

You should find it at the bottom of the unit. Check the labels!!!

mogs01
11.10.2008, 03:21
Hi,

I managed to update BIOS and now my laptop recognizes the battery!
Now I just have to test if the battery lasts longer than an hour, because seemingly one of the problems of toshiba U400 series is that the batteries does not last very long after updating BIOS.
Just have to wait and see, I guess.

bye

mogs01
13.10.2008, 15:01
Hi everybody,

I tested the battery. At "normal" usage the battery lasts for about 2.5 hours. According to the website of the supplier U400-119 has a maximum autonomy of 3.30 hours. So I presume that the battery works fine.
Updating BIOS seems to be the right answer for my problem :)

bye

Message was edited by: mogs01