PDA

View Full Version : Unable to boot Portege S100 after encrypting the HDD with SafeBoot



loungelizard
07.07.2008, 15:57
I am in the process of installing SafeBoot (McAfee Endpoint) full disk encryption on 100+ laptops, most of which are Toshiba. I'm using Device Encryption 5.1.5.0, Release 5300 (515-0015) and I've been able to successfully install it on a number of different Toshiba models, however, the Portege S100 is causing me a major problem. The SafeBoot Client software installs okay on Windows XP SP2 (and SP3) and encrypts the disk as normal but as soon as I restart it fails to boot ever again.

Now, when I first switch on I get:

Starting SafeBoot v5.1
Please wait...

for about a second and then a dialogue box appears in the middle of the screen:

SafeBoot Error
Error: 0xe002001b
No boot disk was found

It never gets to the SafeBoot Logon screen so is still in the pre-boot stage.

I believe this is because this laptop has a build-in SATA RAID controller. We're not using the RAID setup and only have the one original disk installed. The BIOS is the latest version 1.50 and the third system setup screen shows the RAID array state to be 1RAID-0. If I set it to JBOD then I can't even get as far as installing Windows.

So far I have tried replacing the Toshiba RAID driver with the Intel 82801FBM (ICH6M) SATA AHCI 7.0.0.1020 driver. This works fine during Windows installation at the F6 stage and in Windows before encryption. I have even successfully used this driver with a WinTech CD (modified BartPE CD with SafeBoot plug-in) and am able to see the encrypted disk. However, even with this driver I get the same message once encrypted.

I am sure my SafeBoot administration and deployment is set up correctly because the same installation set works fine on a number of different laptop models, just not this one.

Any suggestions would be much appreciated.

Jeffrey
07.07.2008, 16:15
Hi

I’m not expert in “SafeBoot” software. It’s not known to me but I would like to say something about the RAID driver which you have used.

I think it’s a wrong driver. It looks like a SATA driver and not RAID driver.

The Toshiba European driver page provides an *Toshiba RAID driver v 1.3.8.0.*

Please check this!

I would also recommend checking the user manual for Portege S100.
There you can find some details about RAID.

The JBOD means “No RAID settings”. Using this option, Windows cannot be installed in this disk except using the Toshiba Product Recovery DVD/CD

Bye

loungelizard
08.07.2008, 10:12
Thanks Jeffrey for your reply.

You are right in that the Toshiba RAID 1.3.8.0 driver is the one to use and it was the one I was using originally as it's in the corporate build that we use. I was getting the boot error with SafeBoot when using this driver which let me to try alternatives. The Toshiba RAID driver doesn't work with SafeBoot or the WinTech CD so at no point was I able to see the disk once encrypted. The Intel driver allows me to see the disk with the WinTech CD but I'm still getting the boot error if I try to boot from the hard disk. I'm guessing that I'm heading down the right track but I'm by no means certain!

As for the manual, I have already read it as it seems to contain the only information I can find. Having spoken to McAfee they suggested using a legacy/PATA compatibility mode setting in the BIOS but this RAID setting seems to be the only thing there is, which is why I felt I had to at least try the JBOD setting.

Some of the other Toshiba models I've tried (such as the Satellite Pro U300) use Intel SATA drivers at the F6 stage and SafeBoot runs fine on those so I'm not sure why I'm having so much trouble with this one. I'm guessing it might be something to do with the MBR which I believe SafeBoot modifies.

kenneth-539503799
08.08.2008, 22:01
Hi loungelizard,

I have the exact same issue but with the Portege M400 and SafeBoot 5.1.3 and co-incidently work in London as well!

Did you get a solution in the end?

Thanks,
Ken

loungelizard
10.08.2008, 13:03
Hi Ken,

Unfortunately I never did find a solution. I had a couple of support calls open with McAfee to try and resolve this issue but they eventually concluded that unless it was possible to select a legacy or PATA compatible mode in the BIOS then it was never going to work. Our S100 laptops have the latest BIOS and there is no such option and no other BIOS versions are available on the Toshiba website. My final option is to contact Toshiba directly to see if an alternative BIOS is available but I don't hold out much hope on this. I'm not familiar with the M400 but your best bet is to investigate the BIOS options and upgrades available.

Ultimately I've had to identify an alternative full disk encryption option for this model, the one I have evaluated with success is the StoneWood FlagStone Eclypt Corporate drive which is a replacement hard disk that uses hardware encryption. It is significantly more expensive but will allow us to extend the life of these laptops. However, these Eclypt drives don't work with all Toshiba laptops either, I've found it doesn't work with some that have a Phoenix BIOS, specifically the Satellite Pro U300 with the latest BIOS.

I hope you have more success than I have, let us know how you get on.

loungelizard
11.08.2008, 13:38
I have just spoken to Toshiba and the technical guy I spoke to said that as far as he's aware there is no BIOS available for any Toshiba laptops that will allow a legacy PATA compatibility mode.

Looks like I'm going to have to continue investigating the hardware encrypted drive option.

kenplex
14.08.2008, 11:41
Hey Loungelizard,

There maybe a solution to all this, I just spoke to SafeBoot and sent them this conversation and they say to use the latest SafeBoot build 5300, that will work for Portégés. They're going to send me the latest build and I will test deploy this tomorrow on a test server, but that's the only option I have at the moment. If you want to have a go, ask SafeBoot for Pravin and have him send you the latest build too.

Thanks,
Ken

christine J
14.01.2009, 22:50
Hey Guys,

Has anyone tried the latest version of safeboot out to fix this problem? I have the same issue on a Tecra S4 and am wondering how you got on.

smoked
29.09.2009, 20:20
Hello.
I hate to drag up an old thread but I am having the exact same issue and I don't see a resolution ever posted here. I am deploying Safeboot 5.13 to Toshiba Tecra S3's and S4's(among other pcs). All the notebooks from other manufactures are fine, but I get the *No boot disk was found* message on the Tecra's. Safeboot version 4 worked fine, but the first boot after the upgrade to 5.13 produces the message.

I've contacted our McAfee rep and our Toshiba rep, but in the meantime has anyone made any progress on this?

Thanks!