PDA

View Full Version : Satellite Pro L100 does not run after BIOS update



Accessless
30.05.2008, 00:00
Ok the machine is a Toshiba Satellite Pro L100 PSLA4. Problem occurred during a BIOS update from the official Toshiba website. I downloaded the zip file, extracted it and activated the .exe file inside.

The window opened by the .exe was a BIOS flashing program, the .exe also simultaneously wrote a new BIOS file to a temporary folder.
When tried to use the program all I got was an error saying that it couldn't find the new BIOS to input.

I tried again only to get the same error. I then left the laptop for several minutes and when I returned, I found a blank unresponsive laptop.
By unresponsive I mean an obvious lack of BIOS functions i.e. power LED's not changing when plugging in of unplugging from the mains and the fact that I had to pull the battery out to turn the machine off. When the machine is turned on now all it does is check the drives and restarts (no display, no beeps)

What do I do?
The first thing that came to mind was to reset the BIOS.
One problem, I can't find the RTC battery or a jumper switch.

R2D2
30.05.2008, 15:50
Hi George

I cannot say why it happened but I can say what happened.

In my opinion something went wrong during the BIOS update procedure and the ROM modules was not writer properly.

Simply said the BIOS update procedure failed.
In such case you have to contact the ASP in your country for a fix…
The technician should be able to rewrite the ROM module and to update the BIOS again.

Good luck buddy

Cheers

Accessless
30.05.2008, 22:03
I have at least found out why this happened, the program obtained from Toshiba automatically 'attempts' to upgrade the BIOS upon activation. This means that the program engaged with errors without my authorisation. I don't find this very impressive from a company as large and powerful as Toshiba.

Also it may be possible to fix myself if the BIOS installation instructions made sense, extracting the .zip file does not create three sub folders and pressing the F12 key does not start the laptop.