PDA

View Full Version : Satellite Pro L20 PSL2YE: 1GB Ram upgrade does not show in the Bios



killzoneuk
30.08.2007, 19:50
I have just purchased a 1 gig mem stick samsung 4200s 533mhz for my L20.
It doesn't show in the Bios or on the general screen in device manager, but it shows in cpu-z and pz wizard 2007.

I'm very confused, and the bios upgrade on toshibas website doesn't include one for the basic L20 PSL2YE.
I'm just wondering if any of the L20 bios upgrades will work with my machine.

any help would be great because i am so confused, thanks

DennisFarina
02.09.2007, 22:08
Hi,

so you already did a biosupdate on your machine? It´s a little bit confusing that you´re confused since I asking myself what do you mean with
"toshibas website doesn't include one for the basic L20 PSL2YE". Do you mean the bios?

Please give some feedback.

P.s.: you can also try this site for a biosupdate:
http://209.167.114.38/support/Download/ln_byModel.asp

Maybe you will find something.

mattg1
31.10.2007, 18:20
I also have a similar problem with the the Equium L20-198. I purcashed a 1gb module from Crucial to install along side the 512mb that came with the laptop. Tried the modules in both banks and the only one which shows up in the Bios is the new 1gb module even though both installed ok.

Both show up in PC Wizard 2007 with all the info. Updated to the latest Bios and still no change. I've seen a number of threads with the same problem but nobody seems to have found a solution. Both modules work fine on their own but not together. I didn't think DDR2 modules had to be installed in pairs???

At least I have doubled the memory, just a shame that there is 512mb going to waste. Anyone any ideas?

Jayjay
31.10.2007, 18:40
There is a solution;
Just simply use the Toshiba recommended modules!!!
I have noticed that this issue could appear if both modules are not identically and therefore not compatible together.
Use the DDR2 533MHz (PC2-4200) 200-PIN SODIMM modules!
http://www.orcalogic.co.uk/asp/prodtype.asp?prodtype=20336&ft=m&st=3