PDA

View Full Version : Running Fedora core 6 the Satego P100-10U becomes very hot



JL74
08.05.2007, 09:05
Hi all,

I run Fedora Core 6 on my Satego P100-10U Notebook. But there is a problem using
NVIDIA-Driver. After few seconds running Fedora the notebook becomes very hot.
The NVIDIA sensors show me a core temperature about 100-112 Degrees.
Is there a solution, how i can fix this?

with best regards
Johann.

Jeffrey
08.05.2007, 10:33
Hi

As you probably know the Toshiba designs and publish the own graphic drivers for the Toshiba notebooks…these graphic drivers are not the same like the original graphic drivers from graphic card manufacture like nVidia or ATI!
The Toshiba graphic drivers are modified to prevent the graphic cards from overheating!!!

Usually the notebooks don’t provide any special graphic card cooling modules but only the CPU cooling module and therefore the notebook graphic card driver controls the graphic card performance.

If the temperature increases to the critical level the driver slows down the card to decreases the temperature and warmness producing.
The original Nvidia or ATI drivers don’t support such feature!!!
In my opinion this is a reason why the card temperature increases to higher level!!!

Be careful, something like that could damage the graphic card!!!

backflip
10.05.2007, 15:25
I've got the same problem. I can only bypass it by booting with the parameter "acpi=off". That's kind of frustrating because I spent several days patching my DSDT in order to have sound and ACPI. Without ACPI I've got no idea about battery level and I can't use "Standby" or hibernation either.
I heard this problem does not exist when you use the "nv" module (standard nVidia driver), however you won't have 3D acceleration then. This is really bad. I don't know who can change that, nVidia or Toshiba or both.

krantix
10.05.2007, 19:55
same problem with p100-126.... it's related to a buggy bios. Using a custom dsdt should solve most of the problems. I've found post of people that managed to resolve the GPU overheating with bios 2.4, but none with bios > 2.4

:-(

JL74
11.05.2007, 10:52
Disabling ACPI support (ACPI=OFF) holds the core temperature of nVIDIA geForce 900GS constant about 50-60 Degrees.
I could use the "nv" standard driver, but I'm interested on development 3D-Applications on Linux, thus I need support for direct rendering.
Thank you for your reply on my question.
With best regards
Johann