PDA

View Full Version : Sound on the Toshiba Satellite Pro U200-199 Ubuntu Feisty



patrik_k
30.04.2007, 14:21
Hi,

Has anyone got sound working on the Toshiba U200-199? I am running Ubuntu Feisty (2.6.20-15-generic kernel) and have tried both the supplied kernel modules and have compiled the latest Alsa (ALSA 1.0.14rc3). However, sound is still not working.

I have tried
- all models which are listed as options for the snd_hda_intel driver in the alsa documentation
- adding the single_cmd option to the snd_hda_intel driver
- booting the kernel with pci=noacpi
- dumping the ACPI dsdt, recompiling it without errors and loading it from a ramdisk

Depending on the model supplied as option I have got different error messages eg:
- hda_intel: azx_get_response timeout, switching to single_cmd mode...
- ACPI: PCI interrupt for device 0000:00:1b.0 disabled

I am running the latest BIOS update (3.50). Needless to say the sound works great in Windows XP.
I'm looking forward to ANY suggestion on getting sound working on this model.

best regards,
Patrik

Corg
01.05.2007, 17:53
Hi, got the same problem.

Enable the sound in WindowsXP and then switch the "Device Config." setting in the BIOS to "All Devices". This works for me with Ubuntu 7.04 out of the box. If you mute the sound in windows an the BIOS is set to "Setup by OS", windows takes control over some device-setting.

Gruss Corg

patrik_k
01.05.2007, 22:28
Hi,

Thanks a lot Corg! This solved the problem and sound is now working perfectly!

regards,
Patrik