PDA

View Full Version : How to use Mandriva Linux on Qosmio G30-148



ern
09.02.2007, 11:33
Hi,

Ive bought this machine with WXP MCE, and Id like to use some linux distro (dual boot). On my older Toshiba Sattelite A10 I use Mandriva 2006 this way. It works perfect. But, on Qosmio, I have some problems with installing MDV 2006 (nVIDIA GeForce Go 7600, LAN) and shutting down the system...). I would be very happy, if I can use Mandriva on this laptop, but other Linux is better then none for me.

Does anybody have good experiencies with Linux on Qosmio (G30)? I prefer "user friendly" linux - Mandriva, Fedora, SuSE, (K)Ubuntu...
Thank you all and sorry for my english. ;-)

augusztin
09.02.2007, 23:57
What exactly are your problems ? I use Gentoo on my A100-912, looking at hardware you have same CPU (Core 2 Duo), same chipset (Intel 945), same wifi (Intel 3945ABG), same GPU (Go 7600)...

I don't see any reason why it shouldn't work. For Go 7600 you should use binary drivers, for LAN you need e100 module (Intel PRO/100 Network Driver).

Try to describe your problem more detailed, maybe we can help you :-)

ern
11.02.2007, 19:17
Thanks, I have the configuration you've described, except the processor - I have Core Duo.
So, these are my problems: I installed Mandriva with KDE, GNOME and IceWM. I set the screen resolution to 1440x900, but when I start the Qosmio, Mandriva stopped before graphical login screen (the screen blinked between graphical and text screen).

I thought it is because of the resolution, so I reinstalled Mandriva only with IceWM and set resolution to 1280x800. With this settings I could start Ice WM and use installed applications. Problem was, that I couldn't connect to the internet - maybe it is because of my bad settings, so I try to change it.

Second problem was with logging of Mandriva. System stopped in text-mode login screen and I had to shut down Qosmio with power off button.

After that I installed GNOME and KDE, but I could run only IceWM (there wasn't loggin screen with menu KDE/GNOME/IceWM). I don't know the reason.
I've deleted the linux partitions and I search the web, how to run Linux on my machine :-)

But I'm not very advanced linux user (I used only very user friendly Mandriva and some Live CDs - Slax, Danix on Toshiba A10 without problems like now)

Thank you a lot for your suggestions.
H

augusztin
12.02.2007, 00:12
NVidia driver have problems with detecting some resolutions, so until i placed this in Section "Screen" in /etc/X11/xorg.conf the driver refused to work on higher resolution than 640x480 :

SubSection "Display"
Viewport 0 0
Depth 24
Modes "1440x900" "1280x800"
EndSubSection


I use 1440x900 on external panel so the driver is capable to use this resolution :-).

Internet - did you have working interface ? You know, if you don't have DHCP server in your local network then you must set IP, mask, DNS and gateway manually (Mandriva have GUI for this if i remember correctly).

That shutdown problem and the problem with invisible KDE/Gnome is unknown to me.

Maybe you could try opensuse or Ubuntu/Kubuntu/Xubuntu :-)

ern
12.02.2007, 22:36
Thanks again, Im trying to solve theese problems at some Czech (Mandriva)Linux forums and Im downloading a few distros (openSuSe, Ubuntu, new Danix and Mandriva 20007 - with better HW support, I hope) to try them as well.

Ill post here my experiencies and maybe ask for another help. I believe...

I know, that GNU/Linux will work on my machine. :-)

davepotts
08.03.2007, 15:14
gentoo works on a toshiba g30-116

I had some fun sortting out which disk driver to use, then it was the screen, then it was the card-reader, then the wireless, etc After2-5 weeks I had the screen, sound and ethernet all working.

Then I tried ubuntu.

It got the screen, disk, sound right by default.

The wireless dirver detects my personel network, get the sid but does'nt connect, I suspect the that is just a config issue.

The cardreader worked after some hacking.

I would classify gentoo as being right for a man who wants to live on the bleeding edge of software develoment, but I got ubuntu working within an other compare two 2 weeks worth of hacking and recompling an entire operating system. I also manage to turn my machine in to a virtual washing machine with some of the packages installed by usging portage/emerge.
I don't want to start a flame war, but if you want to just inserted and run try ubuntu, otherwise try gentoo, but ensure that yo known your machine very well.

DAve.

ern
14.03.2007, 15:20
Thanks a lot!
Now I run Ubuntu 6.10 on Qosmio. Except card reader and TV tuner everything is working, I guess.

Im still Linux begginer, so after some experiences I can recommend Ubuntu as well. I heard about possibilities of Gentoo, but may be its a bit complicated to me.

Ubuntu Live CD and installing to HDD were absolutely without problems in contrast with Mandriva 2006 or 2007. If I increase my linux knowledge then I try other distro, but now I have no reason for adventure like this.

ern

ole.tange
04.05.2007, 23:22
Could I convince you to try out the KnoppMyth LiveCD? You do not have to install anything. Maybe it can find your tuner?

Get the ISO here ftp://ftp.knoppmyth.net/R5/R5E50 or one of the mirrors: http://mysettopbox.tv/knoppmyth.html

ern
04.06.2007, 08:48
Thanks, Ill try it. Now I run Ubuntu and it works fine, but the TV tuner is still "out of order".