PDA

View Full Version : Satellite Pro 2100: black bars with Nvidia driver on Linux



der.brain
26.01.2007, 00:33
Hi,

i try to install the nvidia driver from the nvidia site
under ubuntu 6.06 and compilation was fine.

Problem is that the resolution is not 1024x768 it start
with 800x600 and a black bar at the right side.

I hear from this problem even under windows.

What i need is the right xorg settings to get
this damend display working.

Hope someone could help even if someone knows
the solution for windows it would be great i
will try to adapt this to linux.

Thank you very much.

brain

Jaba
30.01.2007, 16:14
I donít know a solution for you problem but I cannot believe that such problems appear under Windows. Some drivers for windows support a stretch option and therefore such bars donít appear.
But generally itís not able to install the original NVIDIA driver on the Toshiba notebook under windows. The graphic drivers from the Toshiba page are not the same as the original graphic drivers from the Nvidia or ATI page.

Iím not sure about driver usage with the Linux but I found a nice info page bout the configuration:
http://newsletter.toshiba-tro.de/main/

there you could find some configuration tips for Linux.

augusztin
04.02.2007, 12:05
The solution for this problem should be this :

/etc/modprobe.conf file so that it would use software edid's instead of hardware, as somehow it is not so good with detecting the edid's : options nvidia NVreg_SoftEDIDs=0 NVreg_Mobile=4

But because Ubuntu don't use modprobe.conf you should edit /etc/modprobe.d/aliases and add options there.
After that 'sudo update-modules' and /etc/modules.conf will be created.

Try it, maybe it will work maybe not.

PS: I'm not a Ubuntu user so i can't help you too much with other questions :-).

s1s
11.02.2007, 20:06
Hi,

try this in your xorg.conf (bottom):

-------------------------------------------------------
Section "Screen"
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1024x768"
EndSubSection
EndSection
--------------------------------------------------------

Cheers

dustman
23.02.2007, 16:47
Hello!

I would like to ask where can I find some drivers for my Toshiba Satellite A100-529 with an ATI Radeon XPress 200M graphics card? I tried several distros, and even if in Windows I have 3D support, it doesn't work in Linux...I think it's because of my driver...I downloaded from this site the latest (I think) Linux driver for my class of graphics cards, and after I installed it on Fedora Core 6, it simply cracked...

I had a lot of errors, the display was full of coloured lines, the mouse was acting weird, if I opened a window while having a console window active, the image from that window remained on the console..I dunno, think I installed the wrong driver...:( That's why I would like to know where can I find a decent graphics card driver...Any suggestions are most welcome :)


Cheers!

augusztin
28.02.2007, 16:35
Please don't steal topic next time. You can open new topics anytime. But for your question - you should use fglrx (binary ATI drivers). Please double check if your card is supported by latest driver. If not, then download older one.

attila-538268363
25.03.2007, 23:18
Hi, I have a Satellite 2410 (nvidia geforce4 420, 32 MB -- screen resolution 1024x768)

I've solved the black bar problem this way:

1) creating a file (called for ex. nvidia-fix) in /etc/modprobe.d with:

options nvidia NVreg_SoftEDIDs=0 NVreg_Mobile=1 NVreg_EnableAGPFW=1 NVreg_EnableAGPSBA=1

2) downloading this file (EDID settings) to /usr/lib:

http://core.syscall.org/linux/Toshiba_s_1410.bin

and adding this line to the monitor section of /etc/X11/xorg.conf:

Option "CustomEDID" "DFP-0:/usr/lib/Toshiba_s_1410.bin"

(my complete xorg.conf is at http://core.syscall.org/linux/xorg.conf)

Note: I'm on ubuntu 6.10, using nvidia driver version 1.0-9631 (legacy version compatible with my card, installed using envy http://www.albertomilone.com/nvidia_scripts1.html )

s1s
04.04.2007, 15:30
Hi dustman,

download:
https://a248.e.akamai.net/f/674/9206/0/www2.ati.com/drivers/linux/ati-driver-installer-8.35.5-x86.x86_64.run
and then
sh ati-driver-installer-8.35.5-x86.x86_64.run

have fun.