PDA

View Full Version : Satellite Pro A30: after HDD replacing the BIOS does not see HDD or DVD



quinnray
07.01.2007, 18:14
Hi,

I bought a new Satellite Pro A30 a while back.
Shortly afterwards I noticed the system sometimes
would freeze, with a clicking sound from the HD.
A cold reboot was the only solution.
I was advised to replace the HD which I did but the
problem persisted with the new HD.

I tried a known working HD and the problem still persisted.
By this stage the warranty period was up.
The freezes started happening more regularily, and
now the BIOS doesn't recognise the HD nor DVD drive.
It boots up and then tries to boot from network,
since it can't see HD or DVD drive.

At this stage I think I need a new system board.
Anyone have any other advice or seen this problem
before ?

Thanks,
Ray

Juan28
09.01.2007, 15:33
Hi

What happens if you remove either the CD/DVD drive or the HDD?
Does the notebook recognize one of these devices???
Did you use the devices recommended by Toshiba???

anyway, this sounds very strange and the motherboard malfunction is not impossibleÖ

Silas
09.01.2007, 16:09
Hello Ray

According to your description it can really be something serious. I presume there is still original ODD inside and I really donít understand why this is not recognized properly.

As far as I know SP A30 is delivered with 40 GB HDD. Which one you have now?

quinnray
10.01.2007, 21:41
Hi Juan,

Thanks for your reply.
When I let the laptop cool overnight it seems to
recognise the HD/DVD and will boot, but after apx 10mins
it will freeze, with the accompanying HD clicking.
Then when I try to reboot the BIOS doesn't even
recognise the HD or DVD. I can't even eject the
DVD drive when the BIOS is starting.
I tried removing the HD and DVD separately,
but no luck. The BIOS still doesn't recognise either.
The devices are the ones that came with the laptop
which was bought new and hardly ever used.

Thanks,
Ray.

quinnray
10.01.2007, 21:45
Hi Silas,

Yes it is the original ODD inside.
Trying without this or with 3 differnet HDDs
yields the same result.
It's worth noting as written above, when the
unit is allowed cool for a while it will
temporarily recognise both drives, but will
failing after some time.
The Hitatchi 40GB that came with it is the
one that's in it now, but I don't think the
problem is with the HD.

Thanks,
Ray.

JackBlack
11.01.2007, 15:51
Hello

According to your last post I think itís not a HDD or optical drive problem but either a motherboard or overheating issue.
Iím afraid itís not possible to solve this without any additional help from the technician.
I suppose the service provider will start a diagnostic test to find out whatís wrongÖ
Lets hope the motherboard must be not replaced.

quinnray
11.01.2007, 20:03
Thanks for the reply Jack.
I don't suppose there's any point in upgrading the BIOS ?
I'll probably do that anyway.
The unit is outside warranty so can't bring it to
any service centre. I plan to replace the motherboard
myself. I've done others before.

Tonight I tried to put a new OS on as an experiment.
As expected the unit stalled after a few mins with
the usual HD clicking. Then when rebooting and going
into the BIOS, the HD was listed as NONE.
(usual lists the model number).
The HD clicking sounds as if it's not getting enough
power. It clicks when it's spinning up and seems to
fail and spin down.
I have the motherboard model number so plan to
buy a suitable replacement and replace it.

Thanks for the help all.

Ray.

quinnray
17.01.2007, 12:35
Hi Jack,

I'm beginning to think it's an overheating issue,
as the fan seems to switch on and off regularily.
Even shortly after powerup the fan switches on
and then off again after about 5 secs.
I think I'll get a different CPU, slower
that perhaps gives off less heat..
I'm worried if I try update the BIOS,
the unit will stall half way though rendering
the system board useless.

R

jmatthews
24.01.2007, 10:31
Hello, Sounds to me like you have a problem with the HDD/DVD controller on the MB. Seeing as how they both use the same controller integrated on the motherboard if it goes bad it can start to not see the HDD or the CD. But now your computer fails to see both of them. You will need to replace your MB.