PDA

View Full Version : Satellite Pro L10 won't boot up



DC-538042022
06.11.2006, 12:25
Hi I'm looking at an L10 for a friend, at the moment when turning it on, the fan whirrs up, the hard drive led blinks a few times and the cd drive spins up, but nothing further than that happens. The screen doesn't show any life, no beeps come off it it just sits there doing nothing with the power light on and fan whirring.

So far I've tried attaching a monitor to the vga port, no signal from it. Putting a linux boot cd in the drive, it spins up and sounds like its accessing but I don't think its booting, the screen certainly does nothing, and the hard drive is silent. Finally I tried taking the battery out and running from mains. This didn't change anything.

So at the moment I can't get any diagnosis and I've no idea what could even be wrong with it, does anyone have any ideas?

Eldorado
06.11.2006, 22:02
Hi

As you described itís very difficult to say whatís wrong.
It seems it could be definitely something wrong with the hardware because you cannot see the Toshiba welcome screen at the beginning of the booting.

I donít know if it helps but try to remove the battery for several time disconnect form mains and waitÖ after 30min (canít say the exactly time) try to insert the battery again and connect to the mains. Try to boot again.

If it doesnít helps I suppose you will need an additional help from a technician.