PDA

View Full Version : Cannot get USB port to work after re-installing of SP2 on Satellite Pro L20



StuMcGoo
03.11.2006, 12:41
After re-installing XP Home SP2 and downloading all the updates & Drivers from here I cannot get my USB port to work properly, if I have more than one peripheral plugged in it says "Bandwidth Exceeded".

I have a Behringer BCD2000 which is a souncard/midi controler for DJ mixing, it worked fine before i reinstalled windows, now it clicks and pops when playing tunes, also the ASIO doesn't work when I run Traktor (Dj software) and the program freezes. Any other external sound card wont work either. I've been all through the device manager no conflicts apart from an ! over Serial under hidden devices.

I'm lost, is my only option buying a PCMCIA sound card, it worked fine before so surely there is a software solution to this?

If anyone can help I'd be most appreciative.

Barrie
03.11.2006, 18:48
And which notebook model you have exactly? As far as I know Toshiba has produced many different Satellites in the past 10 years.

Daniel9
04.11.2006, 22:54
Hi,

on the driver download page there should also be a file called "installation instructions".
Maybe it will help to install the drivers in the order given there. Good luck!

Bye

StuMcGoo
08.11.2006, 22:38
Satellite pro L20

Ivan25
09.11.2006, 11:18
Hello

Try to disable USB Error Detection:
1. Right-click My Computer and then click Properties.
2. Select Device Manager to view the Device Manager
3. Locate and click the Universal Serial Bus Controller entry.
4. Double-click Universal Host Controller and then click the “Advanced” tab of the Universal Host Controller Properties.
5. Put a checkmark in the box for Disable USB Error Detection. Click OK.
6. Restart the computer to see if "Bandwidth Exceeded" message occurs again

Did you use recovery media to reinstall WXP? When someone write “it worked before and now not” it is really not easy to say why this happen. Try to configure notebook as before and maybe it will work again. Behringer BCD2000 is not known to me and I don’t know how it works and which software must be preinstalled there.
Can you use different USB devices like external HDD, USB mouse, USB memory stick or printer?