View Full Version : Tecra 9100 does not power up

25.10.2006, 16:05

I got Tecra 9100 Laptop and got POWER PROBLEM.
Basically, it got stuck while booting the OS and I was unable to click or move mouse or do anything. So I held the power button to switch it off. I did not switch it on again straightaway coz I had to go somewhere.

So when I tried to switch it ON next day and it does not want to power up. I can see a GREEN LED LIGHT but can't hear any CPU, FAN, Monitor or Hard Drive sound. When I connect the AC Adapter, I can see the CHARGING LED but nothing else is seems to be powering up.

I also tried to replace the Memory Module but still does not want to power up. I would imagine that the motherboard is not getting POWER so therefore nothing is powering up. But the only thing i do not understand is that why the POWER LIGHT (GREEN LED) is ON unless it has separate power source.

Can someone tell me what should i do?

Thank you

25.10.2006, 17:53
Hi Khawar,

I suggest you try removing both the battery and the AC power supply so that all power to the notebook is extinguished. Then reconnect the AC supply and try to power on the notebook. If this works then re-install the battery. I think that the power supply electronics sometimes get 'stuck' and this procedure usually gets them sorted out.

If the unit still refuses to power on after you have tried the above procedure then I suuspect there must be an internal hardware problem in which case you will need to take the unit to an Authorised Service Partner for rectification.


26.10.2006, 12:19

I agree with Nicky. Remove the battery and try to start the unit with power supply only. If there is no success I presume that there is some problem with power supply electronic on the mainboard.

26.10.2006, 16:04

Thank you so much both of you. I am going to try that and will let you know how it went.

Thank you

27.10.2006, 16:32
HI Nicky

I left the laptop without battery and AC connected for about 20hours and then i reconnected the AC Power without battery and switched it ON but I didn't work first time but when i tried it for the second time, it did manage to Power UP but it got stuck on Windows XP BLACK SCREEN. After that i switched it off again and it never worked again.

What do you suggest now??????? I think all components on motherboard seems to be working and it might just need to be fully discharged........... how long i should keep it without battery and AC power.


Hugo Logt
29.10.2006, 23:18
Hi dude,

Try doing an ATX reset to power it on, if that works... you can focus on the black screen more easily.

Here's what you can do: disconnect battery and adapter... hold the power button for 30secs... then connect ONLY the adapter to have a try.

Good luck!

30.10.2006, 13:26
I donít know what you mean with ďÖand it might just need to be fully dischargedĒ but the fact is, if there is no hardware malfunction the unit should works with AC power supply only. If you can not start the unit (I donít mean OS usage) there is probably some serious problem with motherboard. On this way it is not possible to give you proper diagnostic but it can be power supply electronic.

If there is really no any kind of reaction the unit must be checked properly. What is with power or battery LEDs? You didnít write any word about that. Does any of LEDs blinks and send some code?

Sorry but I am afraid that as end user there is no much to do just contact service in your country.

02.11.2006, 10:08
I had experience with same problem, only solution for you is to visit authorized service center and tell them that you know that this model had one small factory recall, modification, couple years ago. While notebook was still in warranty, that modification was free of charge. Now I believe that that the cost should not be more than 70-80 eur. And of course that LEDs are sending some code, just you are not authorized to decode it. Don't worry, your notebook should be just fine.


05.11.2006, 02:08

I Also seem to have the same problem, I took the machine apart to check all the connections and bit, all look to be fine, put it back together and the labtop worked again for a day. Does anyone know where to get a new board from in the UK ?

Any other suggestions would be good...