PDA

View Full Version : Tecra M5: standby/suspend a with a 2.6 kernel Linux



petew
21.06.2006, 02:02
I'm running linux kernel v2.6.16.20 on a Tecra M5, distro is Debian 3.1 stable. Most things seem to work fine, an annoying problem with the nvidia graphics drivers means that I can't switch to a text console after starting X, but the most annoying thing is that I have to shutdown and startup the machine as there's no way i've yet found to convince it to standby or suspend.

I'm using ACPI. As a fall back i've also attempted APM but it seems there isn't any APM support in the BIOS on this laptop. That's fine, i'd rather be using ACPI, just need to get it working. I've upgraded the BIOS to v1.5.

I've enabled CONFIG_ACPI_SLEEP (have also CONFIG_SMP, CONFIG_SUSPEND_SMP, CONFIG_HOTPLUG_CPU, seem to need the last to then be able to enable CONFIG_ACPI_SLEEP) and CONFIG_SOFTWARE_SUSPEND.
$ cat /sys/power/state
Reports:
mem disk

Not sure where the 'standby' option has gone, without CONFIG_ACPI_SLEEP enabled it reports 'standby mem'.

Running: (in single user mode, using -s at boot, so that minimal amount is running)
$ echo "mem" > /sys/power/state
Things start to happen, screen goes blank with a second or two which then makes it difficult to actually identify what it has started doing/not doing, but it then just sits there, fan is active, can't really tell if the harddisk is still spinning but there's little change other than the screen blanking. Can't then wake it up at all, screen stays blank, no access on the disk as far as I can tell, left it for 10 minutes or so just in case it was have timeout problems, nothing. Only option then is to powercycle (by holding power button down for more than 4 seconds) and boot from scratch again.

Have also tried compiling 2.6.16.9 and applying the suspend2 patches in an attempt to get the machine to suspend to disk, not my ideal choice but any suspend would be good at this point. All patched and compiled ok, (picked 2.6.19.9 simply because suspend2 I knew had clean patches against that kernel version) running 'hibernate' script writes to the file or swap fine, it powers off the laptop fine, but resuming just does not happen. Tried FilesWriter initially and then dropped back to the more common SwapWriter, added 'echo > /proc/suspend2/do_resume' to the initrd and also tried adding a suggested script to /etc/mkinitrd/scripts which appear on a couple of Debian distro suspend2 lists to make initrd play, still no joy.
Tried setting compression=none in the config as I noticed when using FileWriter a problem with the initrd missing the lzf module, rather than messing around trying to add lzf to the initrd I figured disabling compression would at least allow me to test it, still no joy. With SwapWriter I got close, looked like it starts to resume, then the laptop just reboots a few seconds afterwards and then boots normally, all resume info gone. Nothing in the log as far as I can see to suggest there's any problems at all.


Am I missing something completely obvious here? I've searched on several sites, come up with very little. Doesn't look like many people have linux running on a Tecra M5, the few that have report which bits of hardware work, none appear to mention standby/suspend. Or perhaps there luck is just much better than mine!

Does anyone have any suggestions on how I can get this working?? I'd like to be able to 'standby' (S1) the laptop initially so at least the hardware should continue working on resume, then possibly S3/S4 (suspend to ram or disk) later if I can get that working and the hardware to resume well. Only next step I can think of is acpidump but my knowledge of ACPI inner workings is non-existence, other than to know this should work better than it does currently.

All suggestions welcome!

Many thanks,
Pete

Ivan25
22.06.2006, 21:43
Hello

It is also possible that standby or hibernate mode is not important for those users. ;)
In my opinion it is important that operating system runs stabile and that hardware components are recognized properly.

Sorry but I can not help you and hope that some other Tecra M5 user with Linux has more luck than you.

Anyway good luck!

Mannerhagen Tom
10.07.2006, 09:22
Hi Pete

Before I used a distribution that handled StandBy and Hibernation in an easier way, I could invoke the Hibernation function by doing thing a bit differently than You:

Echo 4 > /proc/acpi/sleep

would put the machine to Hibernation.
There is no automatic function behind it to make the unit load the hibernation-file at power up, so you might be forced to handle that manually.
Here's a small list that describes the different modes of SLEEP:

http://lkml.org/lkml/2005/9/15/325

BR

Tom

enafu
17.10.2006, 08:07
i've got a similar problem on my satellite pro m30 machine using suse linux 10.1.

It seems the nvidia graphics driver has not just to be installed but recompiled within the kernel. when that is done reconfigure your x settings.
after all, it is not an acpi problem, but a x problem, since x doesn't restart properly on sleep/suspend.
what could help is to restart your x application by pressing ctrl + alt + backspace.

Further information can be found on the nvidia website /linux drivers and on the related sourceforge.net project website. you also find detailled manuals here to specify and solve your problem.

I've just begun using linux on my laptop and am still troubleshooting some hardware problems, so i've had no time yet to really work on that nvidia/X problem.

grusz : johannes

ivoks
17.10.2006, 16:52
Check out this page:

https://help.ubuntu.com/community/NvidiaLaptopBinaryDriverSuspend

bozso
30.11.2006, 02:56
I had the very same experiment with suspend on my M5. I've tried both the OpenSuse 10.1 and 10.2 RC1, but suspend equally fails. It also does for Fedora Core 5 and 6, though if i install the suspend2 for Fedora 6 from http://mhensler.de/swsusp/ it works out from the box.

Unfortunately i had much more hassle with gettng working wireless and printers compared with the Suse, and also irregular complete freezes occur when i use the soundcard (i.e. listen music).