PDA

View Full Version : Linux on Qosmio G30-116



davidpotts
15.04.2006, 17:51
Has anybody tried to install Linux on this machine, if so which version was it?

I have already tried Suse 10.0 and 9.2, they bailed out with a disk controller error!

Dave.

Mike30
19.04.2006, 12:18
Hi Dave

The Qosmio G30 is the newest unit and I believe that you are one of the first users with this unit. I have no much experience with Linux but I believe that you have this problem because of RAID driver that must be installed at the beginning of the OS installation.

Unfortunately Linux is not supported by Toshiba and I really donít know if Toshiba can offer some solution for this.

Good luck!

R2D2
19.04.2006, 15:16
Hi

Like Mike said the Toshiba doesnít support the Linux OS.
In this case you donít get any Toshiba drivers for your unit.

I recommend using the Windows OS and if you want to use the Linux so try to use a Knoppix or Kannonix Linux distribution. It start from the live CD/DVD and you donít need to install the linux on the HDD.

davidpotts
21.04.2006, 23:21
results sofar
suse 10.00 can not find the disk drives
mandrake loads from the cd rom, the complains about a missing cd rom.
mandrivra loads from the cd rom, finds the desk but the screen wraps.
gentoo loads from the cd, finds the disks, gets the screen right, but only in a reduced node. My attempts at loading the latest nvida driver that resulted in some strange effects. But it does run out of the box gentool.
Still working on a total solution.

I accept that due to the nature of the sd card I will get no support on this issue from Toshiba. But I am hoping that information about the tv tunner might be forthcomming.

alicatinhelsinki
23.04.2006, 10:16
yea i have been using suse 9.3 and have a few similar problems. it seems the kernel # in recent versions of suse (at least 9.3) support the hard disks on my G20 bought 1 year ago. Raid is not supported but is not a problem for me as im runnind dual boot (suse on one HD and windows on the other). The only major problem with the hard discs is if you 'restart' the computer.

The disk doesn't shut down but keeps running. if you just 'shut down' the computer everything is fine. The graphics card has given some problems also. Before installing the nvidia drivers (through YAST is easiest with suse) there were some weird effects on screen making it difficult even to use the package manager. After the installation, this dissappeared but for some reason recently has started to reoccur.

ALSA sound system in KDE doesnt work perfectly but you can play music (mp3 & ogg) after a little experimentation. Overall after getting Suse running on this machine its working well.