PDA

View Full Version : Equium L10 doesn't recognise any wireless PCMCIA card that I install



kshuja
05.04.2006, 23:57
Hi,

I've just bought a brand new Toshiba Equium L10 and I can't get any wireless card to install. I have tried different models from Belkin, Netgear and MSI, all of which work perfectly fine on other laptops but not on this one.

The L10 is a clean Windows XP SP2 build straight from the retailer and I am carrying out the following steps to install the wireless network card:

1. Start Windows XP SP2 and log on as admin
2. Run software for the wireless card
3. Insert wireless card

At this stage, windows only recognises the wireless card as an ethernet adaptor and won't install the drivers. Even if I install it manually and point it specifically to the correct directory, it still fails to pick up the drivers and says that there is nothing in the directory for the hardware that I am installing.

I have the latest BIOS for the L10 and have tried all of the following to no avail:

1. Disable USB legacy support in BIOS
2. Disable built in ethernet
3. Run Toshiba PC Diagnostics (reports that everything is working just fine including PCMCIA)
4. Rebuild laptop using supplied Toshiba DVD

Does anyone have any idea what could possibly be wrong? This is driving me crazy and I've never had this kind of issue with any other laptop. Is this a known fault with Toshiba laptops and what's the fix?
Is it a Win XP SP2 problem? Is my laptop faulty?

Thanks in advance.

Regards,

K.



[Edited by: admin on 06-Apr-06 06:51]

Jeffrey
07.04.2006, 21:11
Can you post the details of this card?
Did you contact the PCMCIA card manufacture for support? Maybe there is a new driver release for this card.

I have noticed some problems with a Vodafone PCMICA card on a Satellite P10. This card has caused a blue screen on the unit. Well, the disabling of hyper threading technology in the BIOS has solved this issue. On another cards the new driver release has also solved some strange problems.

However, what I would say is there are many things which could have a bad influence.

Firstly I would recommend to ask the card manufacture for a support.

kshuja
09.04.2006, 21:48
Thank you for the reply. I have tried various models of wifi cards including Belkin Pre-N, NetGear RangeMAX and a standard MSI G wifi card. I've got the latest drivers for all the cards and none of the card manufacturers will help since the cards work fine in other laptops.

The Equium BIOS is simple to say the least and offers very few options for configuration.

Regards,

K. Shuja

sanremo
10.04.2006, 20:58
Hi Shuja

It is really not easy to say what is wrong there. On this way it is not possible to give you some precise answer. Try to contact your local dealer. Maybe he can help you.
Anyway try to contact card producer and ask them what the problem can be. They must have enough experience with own products.

Check also card manufacturer’s support page.

Good luck!!!

kshuja
12.04.2006, 10:59
Thanks to all who replied, it turned out that the PCMCIA controller was faulty. I returned it to Toshiba and got it repaired under the warranty.

Regards,

K