PDA

View Full Version : Satellite M70: WLAN connection lost



vellu
10.02.2006, 20:34
Hello!

I have Satellite M70 and I use integrated Intel WLAN card 2200bg. I have the latest drivers downloaded from Toshiba web site and Asus WLAN router w520g with latest firmware. Connection signal is excellent but sometimes actually very often connection is lost for 5-10 seconds.... I am downloading files all the time so there is no idle time in network traffic.

How can I inspect what is reason for losting connection?
Could authentication method or channel mode be a reason for problems?

JackBlack
10.02.2006, 20:41
Hi

Please check all another topics in the forum about the similar issues with a Intel 2200BG wireless card. I have read some topics and it seems that the driver update with the wireless driver from the Intel website should solve this connection problem.
http://downloadfinder.intel.com/scripts-df-external/Product_Filter.aspx?ProductID=1637&lang=eng

vellu
11.02.2006, 11:41
Hi!

I updated my driver(latest one from intel website) and problem still exists. But now with Intel Wireless utility I can see error messages when connection goes down. I also opened support case to Intel about this problem. Let's see what they suggest.

I have also tested different kind of variations of configurations (power settings etc.) but no helps!

Now I am testing WLAN connection without authentication and it seems to work ok without connection lost. I will test different kind of authentication methods because i really want to see what authentication causes problems.

One thing I can say more. If I want to see connection break as soon as possible, I have to generete traffic with different kind of p2p programs and I also ping my router (default gateway) with command ping -t -l 1500 same time.

kajser
11.02.2006, 22:53
I have similar problems on my M60. It seems that the problems occurs with many different routers so, probably, the problem is in the wireless card. I´m trying to solve it mixing different drivers because no one of them, by itself, solve the problem for me. When the signal lost, it´s imposible to re-connect unless i poweroff-poweron the router. Amazing.

I will inform about my results.



[Edited by: admin]

vellu
12.02.2006, 11:59
Hi!

It's sure that core of this connection ost problem is Intel wifi. In My case I don't have to poweroff-poweron to get connection back.

I hope that Intel suppport can really do something.

Have you tested open WLAN? I mean that no authentication at all? If you have does problem still exists?

Hargaard
12.02.2006, 16:45
I have a simular problem. I don't loose my Wlan connection but it is extremly slow. My notebook is a M70-144 and my wireless card is a Intel Pro Wireless 2200 BG. I have updated to the latest driver, men it did'nt help. I have other wireless computers and they function very vell.
What should I do?

Best regards
Hargaard

vellu
14.02.2006, 04:07
PSP (Power Save Polling) Causes Connection Issues With Some Access Points

http://support.intel.com/support/wireless/wlan/sb/cs-006205.htm

vellu
16.02.2006, 22:26
Bad news for everyone who owns Toshiba and has intel WLAN card.....


Hello,

Thank you for contacting Intel(R) Technical Support.

If the adapter came integrated in the computer please be aware that in this case the adapter is an OEM (Original Equipment Manufacturer) product , please contact the computer manufacturer as they are familiar with the total configuration of your integrated system and the way all the features that interact with each other.




By the way PSP was not problem....

vellu
17.02.2006, 08:47
Any good news? Are you still investigating more?
Intel says that our should contact Toshiba support(OEM).

Maybe Toshiba can't do anything about this problem because problem might be a router.
It feels that almost everybody has some connection problems with Intel card.



[Edited by: admin on 17-Feb-06 07:01]

Jimi
17.02.2006, 12:00
Hi

I have read about the WLan problems with the Intel 2200 BG WLan card. But usually the Intel driver update has solved the most issues.
In your case it’s possible that the router is a reason for the short connections brakes.
It would be very interesting to know if this issue occurs also on other routers.

Joao
17.02.2006, 15:36
Hi

I didn’t expect other Intel explanation. It is “usual” that notebook manufacturer is responsible for everything if something doesn’t work well. The fact is that this new INTEL card has some new features and INTEl offers this card because of Centrino concept (chipset, processor and WLAN card).

Toshiba uses this concept and INTEL delivered the parts. I believe if there is something wrong the full responsibility is on hardware manufacturer. Usually the functionality must be tested before it can be offered to notebook manufacturers.

If you read other forums many users have noticed the same using this card on many non-Toshiba notebooks but with Centrino platform.

Bye

vellu
17.02.2006, 19:44
I called to Toshiba support today and they said that problem should be in 802.1g. They had updated driver already for tecra M3 but not for satellite yet.

Quick solution should be using 802.1b!

vellu
21.02.2006, 17:11
802.1b works slow but corretly. No connection lost anymore! So now we have to wait updated driver from Toshiba. Updated version is only availabe ror Tecra users now.

ciyounck
21.02.2006, 18:07
same problem with a friend, but with a M70-148 with the intel wireless card.

Good to know, going to tell him to change the setting to 802.1b temporarily.

Have they said how long it's gonna take to update this driver?

JackBlack
21.02.2006, 18:30
Hi

Try to install the Intel Wlan driver V 9.0.2.31
This driver was updated on 19/12/05.
This driver you will find in the Tecra M3 and M2 section but it should also run on other units.

vellu
21.02.2006, 18:58
They try to get updated driver as soon as possible to all models. Hard to say exact time. Tecra (updated) driver will not correct problem in Satellita models. I tested that. Drivers are little bit different depending model unless both models have same intel wlan card...

vellu
21.02.2006, 19:00
That driver is optimized for Tecra. It will not correct connection losts in Satellite notebooks. I tested that.
We have to wait updated driver for Satellite models.

ciyounck
22.02.2006, 14:05
Hopefully it is solved quickly.

It's a pretty annoying issue.



[Edited by: admin]

laurent0001
27.02.2006, 14:23
I have the same issue. The ping -t is working fine for 1-2 minutes then timeout for 10-20 secs then works again...
I called Toshiba (France) this morning. They asked me to update to the latest Intel driver (9.0.4.8)and to set the power setting (PSP) to max in the device settings. I will try this.

ciyounck
27.02.2006, 14:33
let us known if it works with the driver. The PSP to max i've already tried, but doesn't solve the problem.

vellu
27.02.2006, 17:30
Unbelievable! Totally different answer for me (Sweden, Finland).


You should not install Intel drivers because that does not help. I have tested it. There is a problem with 802.1g and Toshiba will publish updated drivers for all models (which have intel wlan card). Actually there is updated drivers already for Tecra but not for Satellite. For other models.. well i don't know.

OEM Supplied vs. Intel® Generic Software:

It is recommended that you obtain and utilize the software provided via your laptop manufacturer.

Intel® is a supplier of laptop components and does not manufacture or sell complete laptop systems. The software provided by Intel below is a generic version. Each laptop computer original equipment manufacturer (OEM) may have altered the features, incorporated customizations, or made other changes to the software or software packaging they provide. The software provided has not been verified by your laptop manufacturer as to compatibility or other operation.

Intel or the laptop computer original equipment manufacturer (OEM) may not provide technical support for some or all issues that could arise from the usage of this software.


Note! You cannot compare Toshiba version and with Intel versions. They are not sychronized.

Intel drivers cannot change some setting with toshiba chipset. Toshiba drivers can.

laurent0001
28.02.2006, 09:44
As recommended by Toshiba (France), I have installed the Inter driver 9.0.4.8 (that is the latest device driver but not the lastest Intel GUI software - see Intel web site) http://support.intel.com/support/wireless/wlan/sb/CS-010623.htm and set the PSP option to maximum. It did fix my problem. Now the connection is much faster without lost after a couple of hours.
However the Intel Wireless Proset software comes with the driver installation and the Wifi connection is no longer managed by Windows/XP but by the Intel software. Do we absolutely need this Intel software ? Can't we just install the device driver and let it managed by Windows as before ?

Eldorado
28.02.2006, 11:20
Hi

In my opinion it’s only necessary to install the driver. The Intel utility is not needed. The windows can also configure the WLan card.

But nice to hear that it works and you have solved the problem

laurent0001
28.02.2006, 12:48
Do you think that's simply removing the Intel software will work ? Does it also remove the device driver ?

Eldorado
28.02.2006, 12:53
Hi

Unfortunately, I’m not sure about this procedure but if it’s possible so the only way is to remove it from the ‘Add & remove programs’ in the control panel.
But if all work ok, skip it.

vellu
28.02.2006, 18:17
Have you really tested your new driver completely? I also tested it and I saw that you must put throughput much that you can see is connection lost really happening again. So I suggest you to download some big files and pinging same ti to your router with option ping 192.168.1.1 -t -l 1500.

In my case new driver did not correct problem althought connection was working better.

vellu
28.02.2006, 18:33
Sorry if I was wrong! I noticed now that I had tested version 9.0.3.9. I will also test now version 9.0.4.8 which is the newest one.

By the way have you tested PSP set to as default action?
I use ASUS router and it should support WiFi alliance WMM power save mechanism(PSP includedin WMM?).

laurent0001
28.02.2006, 22:30
I installed device driver 9.0.4.8 together with the Intel Proset software (I was using standard Toshiba 9.0.1.9 driver before), and set the PSP option (using Intel config software) to maximum. I did not try anything else yet.
I used the same command ping -t 192.168.1.1. Before the upgrade I got timeout after 30 seconds, now it's working ok and the response time is much better. I have a Netgear DG834GT router (don't know whether the PSP feature is supported or not). I will do further tests. Please post your results once you've done your upgrade.

vellu
28.02.2006, 22:44
What laptop model you have (Satellite)?
Toshiba's latest driver for satellite 9.0.2.25 worked
pretty well for me, much longer than your 30 seconds.

Now I have done the upgrade (without intel proset software). I lost connection already once but after that I set PSP to maximum. So I also will do further tests now. But it's not good that we have to use psp to set max to get wlan working properly. It's waisting battery much more....

ciyounck
01.03.2006, 00:24
with the model my friend uses, the problem seems to be solved. for the moment no timeouts.

I'm gonna test tomorrow a little bit more to be sure.

but now the systems works with the intel wireless driver and no more with the windows wireless system. but it looks nice..think i gonna let it be on the system.

laurent0001
01.03.2006, 12:12
I have a Satellite M70. I don't think the PSP option set to max would waste the battery a lot.

jmatthews
01.03.2006, 16:50
Hi everyone,

I just want to add that, to get a quick professional opinion on this subject, take the portable to your authorised service provider. There are sometimes fixes that come out specifically to ASP's, who have insider knowledge to fix things. It would save you all the banging head on keyboard moments associated with this wireless dilemma.